$re = '/^/.+/question-[0-9]/.+/';
$str = 'static/IOSfiles/MicrosoftTeams-image_4.png';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);