re = /^\/.+\/question-[0-9]\/.+/
str = 'static/IOSfiles/MicrosoftTeams-image_4.png'
# Print the match result
str.match(re) do |match|
puts match.to_s
end