$re = '/(fprintf(\s*)\((\s*\S+\s*)[,])([^\"])/m';
$str = 'fprintf ( out , os.str().c_str());';
$subst = "\1 \"%s\",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;