import re
regex = re.compile(r"(fprintf(\s*)\((\s*\S+\s*)[,])([^\"])", flags=re.MULTILINE)
test_str = "fprintf ( out , os.str().c_str());"
subst = "\\1 \"%s\","
result = regex.sub(subst, test_str)
if result:
print(result)