// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(fprintf(\s*)\((\s*\S+\s*)[,])([^\"])"#).unwrap();
let string = "fprintf ( out , os.str().c_str());";
let substitution = "\\1 \"%s\",";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}