using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z]\S*(?:\s+[^A-Z\s]\S*)*";
string input = @"Animals Chicken helmet Animal baby kids Crazy 6 yo monkey Baby white-black horse";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}