// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[A-Z]\S*(?:\s+[^A-Z\s]\S*)*").unwrap();
let string = "Animals Chicken helmet Animal baby kids Crazy 6 yo monkey Baby white-black horse";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}