$re = '/\b[A-Z]\S*(?:\s+[^A-Z\s]\S*)*/m';
$str = 'Animals Chicken helmet Animal baby kids Crazy 6 yo monkey Baby white-black horse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);