re = /\b[A-Z]\S*(?:\s+[^A-Z\s]\S*)*/m
str = 'Animals Chicken helmet Animal baby kids Crazy 6 yo monkey Baby white-black horse'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end