#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=\{((?:[^{}]++|\{(?1)\})++)\})"
Local $sString = "hello hello - helleo" & @CRLF & _
" ba blab blab alb" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
" "collection1": [" & @CRLF & _
" {" & @CRLF & _
" "property1": {" & @CRLF & _
" "text": "O.P.\nA few forum post ads.\nThanks."," & @CRLF & _
" "href": "bla"" & @CRLF & _
" }," & @CRLF & _
" "property2": "posted 2010-Jul-26, 1:21 am"" & @CRLF & _
" }," & @CRLF & _
" ]" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"hello2 hello2 - helleo2" & @CRLF & _
" ba blab blab alb" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
" "collection2": [" & @CRLF & _
" {" & @CRLF & _
" "property1": {" & @CRLF & _
" "text": "O.P.\nA few forum post ads2.\nThanks."," & @CRLF & _
" "href": "bla"" & @CRLF & _
" }," & @CRLF & _
" "property2": "posted 2010-Jul-26, 1:22 am"" & @CRLF & _
" }," & @CRLF & _
" ]" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")