using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\{((?:[^{}]++|\{(?1)\})++)\})";
string input = @"hello hello - helleo
ba blab blab alb
{
""collection1"": [
{
""property1"": {
""text"": ""O.P.\nA few forum post ads.\nThanks."",
""href"": ""bla""
},
""property2"": ""posted 2010-Jul-26, 1:21 am""
},
]
}
hello2 hello2 - helleo2
ba blab blab alb
{
""collection2"": [
{
""property1"": {
""text"": ""O.P.\nA few forum post ads2.\nThanks."",
""href"": ""bla""
},
""property2"": ""posted 2010-Jul-26, 1:22 am""
},
]
}
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}