import re
regex = re.compile(r"(?=\{((?:[^{}]++|\{(?1)\})++)\})")
test_str = ("hello hello - helleo\n"
" ba blab blab alb\n"
" \n\n\n\n"
"{\n"
" \"collection1\": [\n"
" {\n"
" \"property1\": {\n"
" \"text\": \"O.P.\\nA few forum post ads.\\nThanks.\",\n"
" \"href\": \"bla\"\n"
" },\n"
" \"property2\": \"posted 2010-Jul-26, 1:21 am\"\n"
" },\n"
" ]\n"
"}\n\n\n"
"hello2 hello2 - helleo2\n"
" ba blab blab alb\n"
" \n\n\n\n"
"{\n"
" \"collection2\": [\n"
" {\n"
" \"property1\": {\n"
" \"text\": \"O.P.\\nA few forum post ads2.\\nThanks.\",\n"
" \"href\": \"bla\"\n"
" },\n"
" \"property2\": \"posted 2010-Jul-26, 1:22 am\"\n"
" },\n"
" ]\n"
"}\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")