#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-z\.-]+@)([a-z\.-]+)\b"
Local $sString = "Please contact us at: support@github.com. " & @CRLF & _
"Just send email to s.miller@mit.edu and j.hopking@york.ac.uk for more information. " & @CRLF & _
"Many users @ SoftUni confuse email addresses. We @ Softuni.BG provide high-quality training @ home or @ class. –- steve.parker@softuni.de. " & @CRLF & _
"" & @CRLF & _
"info@softuni-bulgaria.org" & @CRLF & _
"kiki@hotmail.co.uk" & @CRLF & _
"no-reply@github.com" & @CRLF & _
"s.peterson@mail.uu.net" & @CRLF & _
"info-bg@software-university.software.academy" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")