import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z\\.-]+@)([a-z\\.-]+)\\b";
final String string = "Please contact us at: support@github.com. \n"
+ "Just send email to s.miller@mit.edu and j.hopking@york.ac.uk for more information. \n"
+ "Many users @ SoftUni confuse email addresses. We @ Softuni.BG provide high-quality training @ home or @ class. –- steve.parker@softuni.de. \n\n"
+ "info@softuni-bulgaria.org\n"
+ "kiki@hotmail.co.uk\n"
+ "no-reply@github.com\n"
+ "s.peterson@mail.uu.net\n"
+ "info-bg@software-university.software.academy\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}