package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-z\.-]+@)([a-z\.-]+)\b`)
var str = `Please contact us at: support@github.com.
Just send email to s.miller@mit.edu and j.hopking@york.ac.uk for more information.
Many users @ SoftUni confuse email addresses. We @ Softuni.BG provide high-quality training @ home or @ class. –- steve.parker@softuni.de.
info@softuni-bulgaria.org
kiki@hotmail.co.uk
no-reply@github.com
s.peterson@mail.uu.net
info-bg@software-university.software.academy
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}