using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({{.+?}})";
string input = @"текст текст текст {{любой_нужный_текст}} текст
текст текст текст {{еще_любой_нужный_текст}}текст текст {{еще_сколько_угодно_раз_нужный_текст}}
текст текст";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}