re = /({{.+?}})/mi
str = 'текст текст текст {{любой_нужный_текст}} текст
текст текст текст {{еще_любой_нужный_текст}}текст текст {{еще_сколько_угодно_раз_нужный_текст}}
текст текст'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end