package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)({{.+?}})`)
var str = `текст текст текст {{любой_нужный_текст}} текст
текст текст текст {{еще_любой_нужный_текст}}текст текст {{еще_сколько_угодно_раз_нужный_текст}}
текст текст`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}