import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{\\{.+?\\}\\})";
final String string = "текст текст текст {{любой_нужный_текст}} текст \n"
+ "текст текст текст {{еще_любой_нужный_текст}}текст текст {{еще_сколько_угодно_раз_нужный_текст}}\n"
+ "текст текст";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}