# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a>.*?<\/a>)\s*| /\1\n/g;t' <<< "hello <a>John Smith</a> hey ho"