use strict;
my $str = 'hello <a>John Smith</a> hey ho';
my $regex = qr/(<a>.*?</a>)\s*| /p;
my $subst = '\\1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";