import Foundation
let pattern = #"(<a>.*?</a>)\s*| "#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"hello <a>John Smith</a> hey ho"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)