const regex = /(<a>.*?</a>)\s*| /g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a>.*?<\/a>)\\s*| ', 'g')
const str = `hello <a>John Smith</a> hey ho`;
const subst = `\1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);