re = /(^[0-9]{1,2}\/[0-9]{1,2}\/[0-9]{1,2}), ([0-9]{1,2}:[0-9]{1,2} [a-zA-Z]{2}) - ([a-z0-9 \S]+?)(:| added|created group) ([a-z0-9 \S\n]+)?/
str = '3/22/16, 12:35 PM - Narayanaswamy Meetup Hsp: Guys Ranjit is proposing to have a Holi walk (not Holy walk) on Thursday 24-3-16. He will put up the proposal and if anyone wishes to join pl co-ordinate with Ranjit'
# Print the match result
str.match(re) do |match|
puts match.to_s
end