const regex = /^(.{1,14}(?<=\S)\b).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.{1,14}(?<=\\S)\\b).*$', 'gm')
const str = `Hell, how is she today ?`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);