use strict;
my $str = 'Hell, how is she today ?';
my $regex = qr/^(.{1,14}(?<=\S)\b).*$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";