re = /^(.{1,14}(?<=\S)\b).*$/m
str = 'Hell, how is she today ?'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result