$re = '/(?!^[~!@#$%^&*().]+$)^([\u4e00-\u9fa5]*|[\da-zA-Z~!@#$%^&*.·\s]*){0,30}$/';
$str = ' ~!@#$%^&**hJ电费Dfd s是 的发送 到 · 水电费水';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);