re = /(?!^[~!@#$%^&*().]+$)^([\u4e00-\u9fa5]*|[\da-zA-Z~!@#$%^&*.·\s]*){0,30}$/
str = ' ~!@#$%^&**hJ电费Dfd s是 的发送 到 · 水电费水'
# Print the match result
str.match(re) do |match|
puts match.to_s
end