import re
regex = re.compile(r"(?!^[~!@#$%^&*().]+$)^([\u4e00-\u9fa5]*|[\da-zA-Z~!@#$%^&*.·\s]*){0,30}$")
test_str = " ~!@#$%^&**hJ电费Dfd s是 的发送 到 · 水电费水"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")