#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?six)\$[0-9](?![0-9])(?=(?:(?!\(\().)*\)\))" & @CRLF & _
""
Local $sString = "other text here $5" & @CRLF & _
"keyword1 -> (( ran$3dom$6t:,ext$9 ))" & @CRLF & _
"keyword1 -> (( ran$2dom$4t:,ext$6 ))" & @CRLF & _
"other text here $7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")