re = /\$[0-9](?![0-9])(?=(?:(?!\(\().)*\)\))
/ix
str = 'other text here $5
keyword1 -> (( ran$3dom$6t:,ext$9 ))
keyword1 -> (( ran$2dom$4t:,ext$6 ))
other text here $7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end