$re = '/\$[0-9](?![0-9])(?=(?:(?!\(\().)*\)\))
/six';
$str = 'other text here $5
keyword1 -> (( ran$3dom$6t:,ext$9 ))
keyword1 -> (( ran$2dom$4t:,ext$6 ))
other text here $7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);