import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$[0-9](?![0-9])(?=(?:(?!\\(\\().)*\\)\\))\n";
final String string = "other text here $5\n"
+ "keyword1 -> (( ran$3dom$6t:,ext$9 ))\n"
+ "keyword1 -> (( ran$2dom$4t:,ext$6 ))\n"
+ "other text here $7";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}