#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^[0-9]{3} [0-9]{2} [0-9]{3} [0-9]{1} [0-9]{4} [0-9]{7}$"
Local $sString = "123 45 678 9 0000 1234567"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)