$re = '/^[0-9]{3} [0-9]{2} [0-9]{3} [0-9]{1} [0-9]{4} [0-9]{7}$/';
$str = '123 45 678 9 0000 1234567';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;