const regex = /^[0-9]{3} [0-9]{2} [0-9]{3} [0-9]{1} [0-9]{4} [0-9]{7}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{3} [0-9]{2} [0-9]{3} [0-9]{1} [0-9]{4} [0-9]{7}$', 'g')
const str = `123 45 678 9 0000 1234567`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);