re = /^[0-9]{3} [0-9]{2} [0-9]{3} [0-9]{1} [0-9]{4} [0-9]{7}$/
str = '123 45 678 9 0000 1234567'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result