#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^)](?![^(]*\))"
Local $sString = "John Smith" & @CRLF & _
"John Smith (RET)" & @CRLF & _
"Mr. John Smith's (RET) (1st)" & @CRLF & _
"John William Smith (RET)" & @CRLF & _
"John"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")