using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^)](?![^(]*\))";
string input = @"John Smith
John Smith (RET)
Mr. John Smith's (RET) (1st)
John William Smith (RET)
John";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}