$re = '/[^)](?![^(]*\))/m';
$str = 'John Smith
John Smith (RET)
Mr. John Smith\'s (RET) (1st)
John William Smith (RET)
John';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);