re = /[^)](?![^(]*\))/m
str = 'John Smith
John Smith (RET)
Mr. John Smith\'s (RET) (1st)
John William Smith (RET)
John'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end