#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https?://(m\.|www\.)?instagram.com(/p/[\w-/]+)"
Local $sString = "https://instagram.com/p/lorem" & @CRLF & _
"https://www.instagram.com/p/ipsum" & @CRLF & _
"https://m.instagram.com/p/dolor" & @CRLF & _
"https://not-instagram.com/p/sit"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")