import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://(m\\.|www\\.)?instagram.com(/p/[\\w-/]+)";
final String string = "https://instagram.com/p/lorem\n"
+ "https://www.instagram.com/p/ipsum\n"
+ "https://m.instagram.com/p/dolor\n"
+ "https://not-instagram.com/p/sit";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}