package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?://(m\.|www\.)?instagram.com(/p/[\w-/]+)`)
var str = `https://instagram.com/p/lorem
https://www.instagram.com/p/ipsum
https://m.instagram.com/p/dolor
https://not-instagram.com/p/sit`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}