$re = '/https?://(m\.|www\.)?instagram.com(/p/[\w-/]+)/';
$str = 'https://instagram.com/p/lorem
https://www.instagram.com/p/ipsum
https://m.instagram.com/p/dolor
https://not-instagram.com/p/sit';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);