# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.+)(\[author\])(.+)//gm;t' <<< "# hosts.inventory [vpc] vpc ec2 [ec2] vpc ec2 [project:children] vpc ec2 [author] [publisher] [dispatcher]"