package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+)(\[author\])(.+)`)
var str = `# hosts.inventory [vpc] vpc ec2 [ec2] vpc ec2 [project:children] vpc ec2 [author] [publisher] [dispatcher]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}