re = /(.+)(\[author\])(.+)/m
str = '# hosts.inventory [vpc] vpc ec2 [ec2] vpc ec2 [project:children] vpc ec2 [author] [publisher] [dispatcher]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result