const regex = /(.+)(\[author\])(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+)(\\[author\\])(.+)', 'gm')
const str = `# hosts.inventory [vpc] vpc ec2 [ec2] vpc ec2 [project:children] vpc ec2 [author] [publisher] [dispatcher]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);